http-01 DCV not working in ACME v2 Test endpoint

We have our own JAVA ACME Client which is tested and running successfully for quite a long time. We are successfully purchasing certificates from Let's Encrypt CA using the client.
Have created an account using the ACME protocol with Buypass Test Endpoint
https://api.test4.buypass.no/acme/directory using the client

I could issue a wildcard certificate by doing DNS DCV successfully. But HTTP-01 DCV fails with the following error.

Error: Error Status : 401
Error type : urn:ietf:params:acme:error:unauthorized
Error detail : Client doesn't have a valid authorization for identifier

I'm properly provisioning my processed token in the proper file under the /.well-known/acme-challenge/ directory path.

Also tried the path /.wellknown/pki-validation/ directory path as mentioned in the below Buypass ACME PDF document.


Still getting the same error.

Not sure where I'm wrong.
Kindly help me in solving this.

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Devarajan


    We have investigated this case and didn’t find any issues with completing the http-01 validation on 27,28 of August.

    However we have added more logging to our solution now to help diagnose possible issues with validation of this type of challenge.


    Please provide us with more details when you experience any errors: like “MDC-correlationId” response header value, which is sent as a response header from our server and also the date/time when it happened.



    Andriy Mahats

  • Status Answered
  • 4 yrs agoLast active
  • 1Replies closed
  • 149Views
  • 2 Following

Buypass Official Community

This is the official community of Buypass.  A Root CA located in Norway.

Sign-up using free email domains have been blocked due to increased spam. https://community.forumbee.com/t/63zsyt/blocked-email-domains